Page 1 of 1

BF4 mouse and keyboard freeze on start

Posted: Wed Dec 30, 2015 9:51 pm
by :FI:Mefisto

I know BF4 is an old news.
I just upgraded my computer a bit to be able to play fallout4, and tried to mess in a field killing bad /good guys in uniforms.

Tried the BF3 when it was released, but sound stuttering, general performance put me off after several tries.
It seems the same idiots created the BF4.

When I start the game (yeah, origin, than opens the website, then i can click to open the damn game and apply to be allowed to click few more times to finally game to load - was is simpler some years ago, or is it just me) in most cases it freezes my controls - both keyboard and mouse, so the only solution is to press the power button to get any reaction. Computer and other applications work ok in the background.
Just like the game/origin messes with the usb settings on start.

Keyboard is just ordinary labtec usb keyboard, mouse is also wired a4tech x747.

Anyone came across this issue and knows the solution?

Re: BF4 mouse and keyboard freeze on start

Posted: Thu Dec 31, 2015 6:14 am
by :FI:Genosse
Hello Adam,

I don't have BF4 installed anymore and I didn't have this issue as long I played it. But maybe this might help:

Frank ;)

Re: BF4 mouse and keyboard freeze on start

Posted: Thu Dec 31, 2015 1:55 pm
by :FI:Mefisto
Thanks Frank!

Tried that before I posted.
I read somewhere that the game remaps usb devices and sometimes they do not synch correctly after that...

I changed also sound settings to headset, turned off all sound notifications, turned on plugin free launch at the site. turned off voip in game which seem to work now...

Update: It didn't :)
Did a bit of testing and as soon as bf4 started keyboard and mouse were gone, control regained after forcing bf4 to shutdown.
What maybe should be mentioned my keyboard and mouse and usb bluetooth dongle( to communicate with headphones ) were plugged in to same usb hub built in into my desk. Once I moved the bluetooth dongle to some other usb (causing my wireless headset range to drop) problem is gone.